BETA

19th December 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [19/12/18 03:44 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [25/12/18 08:25 PM]