BETA

10th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [10/10/19 09:04 PM] with 'Partial Outage'

Issue has been resolved at [10/10/19 09:14 PM]