BETA

10th October 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [10/10/19 03:44 PM] with 'Major Outage'

Issue has been resolved at [10/10/19 03:55 PM]