BETA

7th May 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [07/05/17 04:11 AM] with 'Partial Outage'

Issue has been resolved at [07/05/17 04:12 AM]