BETA

18th December 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [18/12/18 11:21 AM] with 'Partial Outage'

Issue has been resolved at [18/12/18 11:22 AM]