BETA

10th October 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [10/10/19 03:34 AM] with 'Partial Outage'

Issue has been resolved at [10/10/19 07:14 AM]