BETA

18th December 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [18/12/18 04:02 AM] with 'Partial Outage'

Issue has been resolved at [18/12/18 04:07 AM]