BETA

9th October 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [09/10/19 03:14 PM] with 'Major Outage'

Issue has been resolved at [09/10/19 03:24 PM]