BETA

18th December 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [18/12/18 04:02 AM] with 'Partial Outage'

Issue has been resolved at [18/12/18 04:07 AM]