BETA

9th October 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [09/10/19 02:24 PM] with 'Major Outage'

Issue has been resolved at [09/10/19 03:44 PM]