BETA

9th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [09/10/19 08:44 AM] with 'Partial Outage'

Issue has been resolved at [09/10/19 08:54 AM]