BETA

8th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [08/10/19 04:35 PM] with 'Partial Outage'

Issue has been resolved at [08/10/19 04:44 PM]