BETA

18th December 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [18/12/18 03:44 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [18/12/18 03:59 AM]