BETA

7th October 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [07/10/19 12:55 PM] with 'Major Outage'

Issue has been resolved at [07/10/19 01:04 PM]