BETA

7th October 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [07/10/19 11:44 AM] with 'Major Outage'

Issue has been resolved at [07/10/19 02:54 PM]