BETA

5th May 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [05/05/17 05:12 PM] with 'Partial Outage'

Issue has been resolved at [05/05/17 05:13 PM]