BETA

6th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [06/10/19 01:04 PM] with 'Partial Outage'

Issue has been resolved at [06/10/19 01:14 PM]