BETA

18th December 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [18/12/18 03:31 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [18/12/18 03:35 AM]