BETA

5th October 2019

Madhya Pradesh Issue observed for 'Incoming Calls' in Madhya Pradesh Region

Identified at [05/10/19 01:54 PM] with 'Partial Outage'

Issue has been resolved at [05/10/19 02:14 PM]