BETA

4th May 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [04/05/17 10:10 PM] with 'Partial Outage'

Issue has been resolved at [04/05/17 10:11 PM]