BETA

5th October 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [05/10/19 01:35 PM] with 'Major Outage'

Issue has been resolved at [05/10/19 02:04 PM]