BETA

5th October 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [05/10/19 01:24 PM] with 'Major Outage'

Issue has been resolved at [05/10/19 01:35 PM]