BETA

5th October 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [05/10/19 12:44 PM] with 'Major Outage'

Issue has been resolved at [05/10/19 01:15 PM]