BETA

5th October 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [05/10/19 12:04 PM] with 'Major Outage'

Issue has been resolved at [05/10/19 04:14 PM]