BETA

5th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [05/10/19 09:05 AM] with 'Partial Outage'

Issue has been resolved at [05/10/19 09:14 AM]