BETA

4th October 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [04/10/19 06:55 PM] with 'Major Outage'

Issue has been resolved at [04/10/19 07:14 PM]