BETA

4th October 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [04/10/19 02:24 PM] with 'Major Outage'

Issue has been resolved at [04/10/19 02:34 PM]