BETA

4th October 2019

Rajasthan Issue observed for 'Incoming Calls' in Rajasthan Region

Identified at [04/10/19 02:04 PM] with 'Partial Outage'

Issue has been resolved at [04/10/19 05:34 PM]