BETA

14th December 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [14/12/18 12:45 PM] with 'Major Outage'

Issue has been resolved at [14/12/18 12:47 PM]