BETA

13th December 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [12/12/18 08:07 PM] with 'Major Outage'

Issue has been resolved at [12/12/18 08:09 PM]