BETA

4th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [04/10/19 04:15 AM] with 'Partial Outage'

Issue has been resolved at [04/10/19 04:24 AM]