BETA

6th December 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [06/12/18 08:06 PM] with 'Partial Outage'

Issue has been resolved at [06/12/18 08:19 PM]