BETA

6th December 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [06/12/18 05:38 PM] with 'Partial Outage'

Issue has been resolved at [06/12/18 05:42 PM]