BETA

3rd October 2019

Rajasthan Issue observed for 'Incoming Calls' in Rajasthan Region

Identified at [03/10/19 11:45 PM] with 'Partial Outage'

Issue has been resolved at [04/10/19 12:35 AM]