BETA

4th May 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [04/05/17 10:57 AM] with 'Major Outage'

Issue has been resolved at [04/05/17 10:59 AM]