BETA

5th December 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [05/12/18 02:38 PM] with 'Major Outage'

Issue has been resolved at [05/12/18 02:42 PM]