BETA

3rd December 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [03/12/18 06:50 PM] with 'Major Outage'

Issue has been resolved at [03/12/18 06:57 PM]