BETA

3rd December 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [03/12/18 06:33 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [03/12/18 06:57 PM]