BETA

3rd October 2019

Rajasthan Issue observed for 'Incoming Calls' in Rajasthan Region

Identified at [03/10/19 05:04 PM] with 'Partial Outage'

Issue has been resolved at [03/10/19 06:14 PM]