BETA

3rd December 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [03/12/18 06:31 PM] with 'Partial Outage'

Issue has been resolved at [03/12/18 06:41 PM]