BETA

3rd December 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [03/12/18 06:27 PM] with 'Major Outage'

Issue has been resolved at [03/12/18 06:29 PM]