BETA

3rd October 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [03/10/19 02:15 PM] with 'Major Outage'

Issue has been resolved at [03/10/19 02:44 PM]