BETA

30th November 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [30/11/18 10:37 AM] with 'Partial Outage'

Issue has been resolved at [30/11/18 10:47 AM]