BETA

3rd October 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [03/10/19 11:44 AM] with 'Major Outage'

Issue has been resolved at [03/10/19 11:54 AM]