BETA

3rd October 2019

Rajasthan Issue observed for 'Incoming Calls' in Rajasthan Region

Identified at [03/10/19 09:24 AM] with 'Partial Outage'

Issue has been resolved at [03/10/19 10:34 AM]