BETA

30th November 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [30/11/18 02:23 AM] with 'Partial Outage'

Issue has been resolved at [30/11/18 05:12 AM]