BETA

25th November 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [25/11/18 11:42 PM] with 'Partial Outage'

Issue has been resolved at [25/11/18 11:43 PM]