BETA

25th November 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [25/11/18 12:52 PM] with 'Major Outage'

Issue has been resolved at [25/11/18 12:55 PM]