BETA

2nd October 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [02/10/19 11:25 PM] with 'Major Outage'

Issue has been resolved at [02/10/19 11:34 PM]