BETA

23rd November 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [23/11/18 01:47 AM] with 'Partial Outage'

Issue has been resolved at [23/11/18 01:49 AM]